<< Back to Map Development Forum   Search

Posts 1 - 11 of 11   
Map upload problem: Appears small in top left: 8/8/2017 16:23:20

kicorse
Level 57
Report
Hello all. I'm experimenting with trying to produce my first map. Any map I produce, even if it's just two rectangular territories, appears as a very small map in the top left corner of the screen. Here is an example:

https://www.warlight.net/MultiPlayer?DesignMapID=29725

I am using Inkscape, which I downloaded for the purpose and so started with a clean document with default settings.

I found this thread:

https://www.warlight.net/Forum/244160-map-making-problem

and tried to follow the advice there. However, adding/removing/changing the viewbox parameter in XML has no effect. I have the height and width set to 900 px everywhere I can find to do so, including in Document Properties. I do not have any content, visible or otherwise, outside the 900 px square.

Any ideas?
Map upload problem: Appears small in top left: 8/8/2017 17:20:11


Bane 
Level 60
Report
the first link you posted was the link for you to edit the map, you need to post the other one shown in the editor.

ive actually have the same problem on a map im working on. I don't know how to fix it, I just selected everything and enlarged it so that it goes out of bounds and it appeared 'normal' when uploaded after a few min of fenangaling.
Map upload problem: Appears small in top left: 8/8/2017 17:42:32

kicorse
Level 57
Report
Map upload problem: Appears small in top left: 8/8/2017 17:47:37


OnlyThePie
Level 53
Report
So you tried resizing the default box? Make it fairly large, like 1000 px, then select all your stuff in one big drag select, and scale it up to match.
Map upload problem: Appears small in top left: 8/8/2017 17:59:54

kicorse
Level 57
Report
Thanks Bane. The simple solutions are usually the best! A 900x900 px, but with the content being 3000x3000 px, produced something that looks right.... I need to complete the map to ensure it hasn't screwed up things like bonuses, but so far so good.

https://www.warlight.net/SinglePlayer?PreviewMap=67816

Thanks also to OnlyThePie. For the benefit of other people with the same problem, I started with 900x900 px but tried making it 2000x2000 px (and larger, until I hit the pixel limit). Sadly it makes no difference.
Map upload problem: Appears small in top left: 8/8/2017 18:26:18


Cata Cauda
Level 58
Report
And I thought I was the only one with the problem. I have encountered that on all my maps published and all unfinished ones I get the same issue. I have never heard of other people with that problem, so I thought I was doing something wrong. Apparently some accounts are doomed to encounter that and some other not.
Map upload problem: Appears small in top left: 8/8/2017 19:49:29


apollong3
Level 53
Report
This is actually a kinda common problem windows 10 users seem to have. I don't have it, but have seen it a few times, and I believe there is a better way to solve it. There is a thread on this forum about it, but I can't link it right now
Map upload problem: Appears small in top left: 8/8/2017 20:30:33

Fizzer 
Level 58

Warzone Creator
Report
One thing that can sometimes help issues like this is to reset an element's transform. Try these steps in Inkscape:

1. Open the Xml Editor (Ctrl+Shift+X)
2. Select the offending object (in this case, it's the entire map, so find the root "g" node)
3. Look to see if it has a "transform" attribute. If it doesn't, look to its parent or children to try and find one that does that might be the problem object.
4. Select the transform attribute and click the "delete attribute" to delete it.
5. Deleting the attribute will move/scale the object, likely to the wrong place. Drag/scale it back to where it should be normally (this will re-create the transform attribute, which is OK)

Upload again and see if it's fixed. Also if you continually have these problems, you can report it by emailing the svg to me at fizzer@warlight.net

Edited 8/8/2017 20:30:55
Map upload problem: Appears small in top left: 8/20/2017 03:55:07

Toluene
Level 36
Report
So did this ever get fixed or not, because I'm having this problem
Map upload problem: Appears small in top left: 8/20/2017 16:37:16

Toluene
Level 36
Report
This makes absolutely no sense. I deleted the inkscape file and rebuilt a simple test version of the map: same issue. Then I deleted the whole map family: same issue.

Then I made a basic doodle test map, a whole completely new SVG file and map family, and got the same issue. Something on WarLight or inkscape is broken, there's no issue with any particular attribute on your map.
Map upload problem: Appears small in top left: 8/20/2017 16:43:35

Toluene
Level 36
Report
I have fantastic news for everyone struggling with this problem. I have found the solution.

Open XML editor.

Select the SVG

Find the "viewbox" attribute, delete the attribute. Your map should shrink to the corner.

Resize the map to fit the page.
Posts 1 - 11 of 11