<< Back to General Forum   Search

Posts 1 - 4 of 4   
map creation help: 9/15/2009 16:17:06

Wintermute
Level 47
Report
I am messing around with map creation, but I can't seem to see my maps once I upload them. When I open them in Inkscape, I see all my defined objects, but when I open them in the developer tab in Warlight, I see nothing. Any insights?

Thanks
map creation help: 9/15/2009 19:31:34

Fizzer 
Level 58

Warzone Creator
Report
Hi Custos,

I took a look at the svg and it looks like the view box isn't centered at 0,0, so the map is ending up off-screen.

You can fix this by following these steps:

1. Enter the Xml Editor in inkscape (third button from the right)
2. Click the root node at the top of the list (svg:svg)
3. Inspect the viewBox parameter. For WarLight, the first two numbers should be 0,0 (this defines the top-left corner). The next two numbers are the width and height.
4. Set the viewBox to something sane, like "0 0 900 900" (you can adjust the width/height, but they should be less than about 1300)

At this point, zoom out to see the whole map. You should see your objects well outside the new viewbox. This viewbox is what WarLight was looking at, which is why you weren't seeing anything.

Now, just select all your objects and move/resize them to fit in this new viewbox and you should be good to go!

Let me know if you have any more issues.
map creation help: 12/11/2009 16:38:31


les 
Level 6
Report
Similar, but different problem.
I've created a test map, but am only able to see one of the territories. The territories are copied and pasted circles in Inkscape. They all appear to have a valid ID. I've tried re-adding the map several times, modifying class info (removing dash), changing opacities, etc.
Do you know why I'm not seeing all territories?
map creation help: 12/12/2009 22:32:08

Fizzer 
Level 58

Warzone Creator
Report
Hi les,

Can you e-mail the svg to me? I'll have a look.
Posts 1 - 4 of 4