<< Back to Map Development Forum   Search

Posts 1 - 4 of 4   
Problems with Map Development, Please Help!: 8/12/2015 00:07:49

Level 22
Hey guys, I have been having a problem with uploading my map to warlight, and I was wondering if you guys have the problem too. Whenever I click "Create New Map Family" and select one of my maps made through inkscape it says

"There appears to be an issue with this svg file. The svg contains measurements that are in a format other than pixels (such as points, inches, centimeters, percents, etc.) WarLight only supports pixel measurements. Please configure your application to output the svg in pixels, and ensure that percentages aren't used anywhere."

I have gone back numerous times to check the map, created new maps, and copied exactly what other people did in the forums and from Youtube, all of the sources were from 2014 and earlier though - I couldn't find any up-to-date with the newest version of Inkscape, and I'm not able to get older versions. Please shed some light on my problem, if you have made a map in 2015, or tell me if you have the same problem. I really need help.


Edited 8/12/2015 00:09:38
Problems with Map Development, Please Help!: 8/12/2015 00:20:32

Level 58

Warzone Creator
If you create a brand new, blank, svg file, does it still give the error?

If not, then something you're doing is giving the error. You can try uploading after each thing you do until you get the error. That will tell you which thing you're doing is causing the error.

You can also post the SVG file if you want to get more specific help.
Problems with Map Development, Please Help!: 8/12/2015 07:46:51

Level 55
I met with this error more times. I used pixel measurement but the warlight editor detect it as someone else and give me this error message.

How I fixed the problem? In the 'file' menu 'document settings' on the first 'page' tab there are the measurement option. Maybe you checked this and saw there pixel measurement so dont know why the warlight detect other format.

I just changed the measurement from pixel into someone else (for example mm or cm) and then change back into pixel again and then save the document. After that just upload the file again and the problem has solved.

It always worked for me.
Problems with Map Development, Please Help!: 8/12/2015 11:41:59

Level 22
Thanks guys! I found the error. When ever I create a SVG file and go to 'Document Properties' right below in the 'General" section it says "Default units: px" but if you go lower there is another units section that is set to mm, and I all ways looked at the first one. Thanks for the help guys, I was about to give up map making after having this problem for weeks. You're awesome.
Posts 1 - 4 of 4